Aldia's Keep Enhanced Undead drops NOTHING anymore

Aldia's Keep Enhanced Undead drops NOTHING anymore

Postby Eremhaenon » Fri Nov 06, 2015 11:25 am

I posted a topic about this on the game's Steam page but no real help except someone saying I might just be having bad luck. This seems to have gone beyond the reaches of bad luck into outright bug territory.

To begin, as you all may be aware, in the original Dark Souls 2 the only way to get a Chaos Rapier and Chaos Shield was via drops from a caged Enhanced Undead in Aldia's Keep (in SotFS apparently you can buy them from Felkin now - I really need to play that version...). Some time ago I was farming him and got a Malformed Shell (Skull?) and eventually a Chaos Rapier. So I was glad about that. Then I left him alone for a while, made some progress in the game and decided to come back to some enemies to farm for stuff I didn't get from them before, one of them being this thing's Chaos Shield. Short answer: no luck, at all.

Longer answer: I say this goes beyond mere bad luck because I swear to god I've killed this one enemy more than every other enemy and boss I've killed combined. Not only will he not drop the Chaos Shield, he has not dropped ANYTHING at ALL. Which is what makes me really concerned. I'm still in regular NG, bonfire intensity for the area is 1, and because he's long since despawned I've been farming him via Company of Champions. Well, trying to farm him anyway.

What's stranger is that as I've said he DID drop two items before. But since the progress I've been making and coming back he just stopped all of a sudden. I can't remember what set-up I had when I got the two items. I have a Covetous Gold Serpent Ring +2 now I know that I ascetic'd the Gargoyles fight for the sole purpose of getting, and have long since pawned off Gold Serpent Ring +0 and +1 to Gavlan's Wheels and Deals. Not knowing how item discovery even works in this game (why oh why did they have to make this an invisible stat with no concrete information anywhere as to how it functions), I'm not sure if I made a mistake here, like if somehow too much item discovery is preventing him from dropping anything? Then again, I tried a TON of different set-ups, ring on, ring off, Jester's, Prisoner's Hood, Traveling Merchant Hat, Symbol of Avarice, Tatters, Watchdragon Parma, one time I tried some Rusted Coins (which I find to be useless items in all honesty) all in different combinations and quantities. Hell I even tried killing him a few times with no item discovery items on at all to see if that did anything. I wouldn't be surprised if a quarter of the hours I've put into this was spent just farming this thing for one stupid shield (probably not literally that much but it's been a LOT of hours and the poor thing has died many deaths but he doesn't want give up that shield of his... or anything else for that matter ever since I got his Chaos Rapier).

I just want to know what the hell is going on here. I can farm other enemies for their things just fine. But there's something wrong with this one enemy. If you had any idea of how long I've spent farming him you would understand why I've concluded this is some glitch that just somehow occurred with this enemy. Would setting the Bonfire Intensity up a notch do anything? I've been considering doing that but my endeavors with bonfire ascetics has so far been a risky endeavor. Bosses I've ascetic'd to get their items were surprising in how significantly more difficult they were. Belfry Gargoyles which I took down the first time I fought them slaughtered me several times before I got my +2 Gold Ring. The skeletons in Executioner's Chariot were always a pain but this time they were outright massacring me and I had to eventually use Alluring Skulls for the fight just to survive long enough to get to the second phase in which the horse actually killed me... once, then got it the next time. I didn't die to my ascetic'd Mytha, Najka, and Skeleton Lords fights but when they actually hit me they took a pretty big chunk of health off of me. I've toyed with ascetics in a number of areas but I don't want to go into NG+ with almost every area being NG++ caliber (though I know at least a few I will have to deal with that).

But anyway, that was just a thought on what to possibly do with this Chaos Shield business, if there is some bug causing the item drops to be "stuck" and if an ascetic will "unstick" it? Or going to NG+ will reset things? Or something? Just... what is happening? This can't be just bad luck. It has transcended bad luck. This is the heat death of the universe of luck. I am sincerely convinced that trying to farm him any further is just wasting my time if this is indeed a bug but I don't know what to do about it. I don't want to resort to cheating programs just to add this shield in my inventory but if it somehow comes to that... :(
Posts: 9
Joined: Sat Aug 29, 2015 7:39 pm
Country: United States (us)


Return to Dark Souls 2 Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

  • Advertisement